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DAQ Quick Start Guide for NI-DAQ  7.0
This guide describes how to install NI-DAQ 7.0 driver software and a data 
acquisition (DAQ) device and confirm your device is operating properly. 

This guide does not apply to NI-DAQ for the Macintosh operating system, 
Mac OS. Refer to the NI-DAQ for Macintosh distribution.
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Conventions
The following conventions are used in this guide.

» The » symbol leads you through nested menu items and dialog box options 
to a final action. The sequence File»Page Setup»Options directs you to 
pull down the File menu, select the Page Setup item, and select Options 
from the last dialog box.

This icon denotes a tip, which alerts you to advisory information.

This icon denotes a note, which alerts you to important information.

This icon denotes a caution, which advises you of precautions to take to 
avoid injury, data loss, or a system crash.

bold Bold text denotes items that you must select or click in the software, such 
as menu items and dialog box options, and the names of LEDs. 

italic Italic text denotes a cross reference or an introduction to a key concept. This 
font also denotes text that is a placeholder for a word or value that you must 
supply.

monospace Text in this font denotes text or characters that you should enter from the 
keyboard, the proper names of disk drives, paths, directories, programs, 
functions, filenames, and extensions.

monospace italic Italic text in this font denotes text that is a placeholder for a word or value 
that you must supply.

Where Do I Start?
Figure 1 shows the steps for installing NI-DAQ 7.0 and a DAQ device, and 
where to find the relevant information in the documentation.
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Figure 1.  Installation Process Overview

* Device signal and terminal connections are available online from the Measurement & Automation Explorer Help for Traditional 
NI-DAQ and Measurement & Automation Explorer Help for NI-DAQmx, which you access from the Measurement & Automation 
Explorer (MAX) Help menu. In addition, device signal connections and additional signal information is in the device documentation 
available from the Device Document Browser. Refer to Step 10. Browse or Install Device Documentation for instructions on using 
the device documentation.

Check the NI-DAQ 7.0 Readme
for Operating System, Application Software, Programming

Language, and Device Support in NI-DAQ 7.0 to see which parts of 
NI-DAQ 7.0 to install and use in your application. Do not install 
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unsupported components.
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Automation Explorer Help for 
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and for NI-DAQmx, and the device terminal help*.

Read about the new NI-DAQmx application programming
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Do you need to
install an SCXI or switch 

module? 

No
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NI-DAQ 7.0 Software
National Instruments measurement devices are packaged with NI-DAQ 
driver software, an extensive library of functions and VIs you can call from 
your application software, such as LabVIEW or LabWindows™/CVI™, 
to program all the features of your NI measurement devices. Measurement 
devices include DAQ devices such as the E Series multifunction I/O (MIO) 
devices, SCXI signal conditioning modules, and switch modules. Driver 
software has an application programming interface (API), which is a 
library of VIs, functions, classes, attributes, and properties for creating 
applications for your device.

NI-DAQ 7.0 includes two NI-DAQ drivers, each with its own API, 
hardware configuration, and software configuration. 

• Traditional NI-DAQ is an upgrade to the earlier version of NI-DAQ. 
Traditional NI-DAQ has the same VIs and functions and works the 
same way as NI-DAQ 6.9.3, except that you can use Traditional 
NI-DAQ and NI-DAQmx on the same computer. 

• NI-DAQmx is the latest NI-DAQ driver with new VIs and functions 
and development tools for programming measurement devices. 
NI-DAQmx has advantages over Traditional NI-DAQ.

– DAQ Assistant—a graphical way to configure channels and 
measurement tasks for your device for use in LabVIEW, 
LabWindows/CVI, and Measurement Studio. You also can use the 
DAQ Assistant to generate NI-DAQmx code for the task for use in 
NI application software programs.

– Increased performance, including faster single-point analog I/O 
and multithreading.

– Simpler, more intuitive APIs for creating DAQ applications using 
fewer functions and VIs than earlier versions of NI-DAQ.

– Expanded functionality in the NI-DAQmx API for LabVIEW, 
including property nodes for data acquisition and improved 
waveform data type support for analog I/O.

– Similar APIs and functionality for ANSI C, LabWindows/CVI, 
and Measurement Studio, including native .NET and C++ 
interfaces.

Who Can Use NI-DAQmx
Install and use NI-DAQmx if the following situations apply:

• You are using Windows.

• You are using only a PCI or PXI E Series multifunction DAQ device 
and/or a supported SCXI or SCC module. 
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• If you are using NI application software such as LabVIEW, 
LabWindows/CVI, or Measurement Studio, you must have version 7.0 
or later of the application software to use NI-DAQmx.

Note If you use one of the Measurement Studio .NET languages, you must use 
NI-DAQmx.

Who Must Use Traditional NI-DAQ
Install and use Traditional NI-DAQ if one of the following situations apply:

• You have a device that is not supported by NI-DAQmx, such as the AT 
E Series multifunction DAQ devices, digital I/O (DIO) devices, and 
dynamic signal acquisition devices.

• You are using an SCXI-1530, SCXI-1531, or SCXI-1540 device with 
accelerometer, linear-voltage differential transformer (LVDT), or 
rotary variable-differential transformer (RVDT) virtual channels, 
which are not supported by NI-DAQmx. 

• You are using the LabVIEW Real-Time (RT) module.

• You are upgrading from NI-DAQ 6.9.x and have existing applications 
that you do not want to port now. 

• You are using a version of LabVIEW, LabWindows/CVI, or 
Measurement Studio earlier than version 7.0.

• You are using Visual Basic 6.0.

Note The earliest version of NI application software supported by Traditional NI-DAQ is 
version 6.0. LabVIEW, LabWindows/CVI, or Measurement Studio versions 6.x can use 
Traditional NI-DAQ from the NI-DAQ 7.0 distribution.

No Longer Supported in Traditional NI-DAQ
The following items supported by NI-DAQ 6.9.3 are no longer supported 
in Traditional NI-DAQ. 

• NI LabVIEW, LabWindows/CVI, or Measurement Studio application 
software versions earlier than 6.0

• Windows 95

• Some older devices, such as the 1200 Series multifunction DAQ 
devices, VXI DAQ devices, or remote SCXI devices

Refer to the Operating System, Application Software, Programming 
Language, and Device Support in NI-DAQ 7.0 section at the end of this 
guide for the list of supported and unsupported items. 
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How NI-DAQ Fits into Your System
Figure 2 depicts the measurement system overview, showing the path of 
real-world physical phenomena to your measurement application. 

 

Figure 2.  Measurement System Overview
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manipulates the data so it can appear in a graph, chart, or file for a report. 
The software also controls the measurement system, telling the 
measurement device when and from which channels to acquire or generate 
data.

NI measurement devices and application software are packaged with 
NI-DAQ driver software to program all the features of your NI 
measurement device such as configuring, acquiring, and generating data 
from, and sending data to NI measurement devices. Using NI-DAQ saves 
you from having to write these programs yourself. Application software, 
such as LabVIEW, sends the commands to the driver, such as acquire and 
return a thermocouple reading, and then displays and analyzes the data 
acquired.

You can use the NI-DAQ driver from LabVIEW or from any programming 
environment that supports calling dynamic link libraries (DLLs) through 
ANSI C interfaces. Regardless of the programming environment, your 
DAQ application uses NI-DAQ, as illustrated in Figure 2. 

Step 1. Confirm That You Have Installed the Correct 
Application Software Version

If you are using NI application software, including LabVIEW, 
LabWindows/CVI, and Measurement Studio, install it now. You must use 
NI application software version 7.0 or later with NI-DAQmx. You can use 
NI application software version 6.0 or later with Traditional NI-DAQ. 
Refer to the Operating System, Application Software, Programming 
Language, and Device Support in NI-DAQ 7.0 section at the end of this 
guide.

Tip If you have an existing application written with an earlier version of your application 
software or NI-DAQ, make a backup copy of the application. You then can upgrade your 
software and modify the application. If you want to use the original application unchanged 
with the Traditional NI-DAQ API, you can use the backup copy.

Step 2. Uninstall NI-DAQ if You Are Upgrading from a 
Previous Version

If you are upgrading to NI-DAQ 7.0 from a previous version, uninstall 
the earlier version of NI-DAQ before installing the current version. 
Use Control Panels»Add/Remove Programs. Refer to ni.com/
support/install for operating system-specific uninstallation 
instructions. 
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Step 3. Install the NI-DAQ 7.0 Software

Insert the CD

The NI-DAQ 7.0 installer should open automatically. If not, select 
Start»Run. Enter x:\setup.exe, where x is the letter of the CD drive. 
For troubleshooting and operating system-specific instructions, refer to the 
Hardware Installation Wizard at ni.com/support/install.

Caution Do not install NI-DAQ 7.0 if your existing applications include unsupported 
components. Before installing the software, refer to the NI-DAQ 7.0 Readme file on the 
NI-DAQ 7.0 CD or the Operating System, Application Software, Programming Language, 
and Device Support in NI-DAQ 7.0 section at the end of this guide. 

Tip Install your driver software before installing new devices, or Windows may not detect 
your device, and you may see warnings asking you to install the driver.

Choose the API/s to Install

Caution NI-DAQ 7.0 cannot exist on the same system with earlier versions of NI-DAQ. 
When you install NI-DAQ 7.0, Traditional NI-DAQ replaces NI-DAQ 6.9.x and earlier 
versions, as well as any support files installed by that earlier version. Older versions of 
NI-DAQ are removed when you install NI-DAQmx. 

NI-DAQ 7.0 contains several drivers and their APIs—Traditional 
NI-DAQ, NI-DAQmx, and NI-SWITCH. You can install any or all of the 
drivers, depending on the devices you are using. Refer to the NI-DAQ 7.0 
Software section at the beginning of this guide for descriptions of 
Traditional NI-DAQ and NI-DAQmx. 

Install and use NI-SWITCH to program an NI switch module. NI-SWITCH 
is an IVI-compliant switch instrument driver that supports all NI switch 
modules. NI-SWITCH has an interactive soft front panel for testing and 
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troubleshooting switch applications. NI-SWITCH 2.0 requires you to 
install NI-DAQmx and NI-VISA 3.0. 

Install Support Files
The NI-DAQ 7.0 installer detects the NI software installed on the system 
and automatically selects the latest versions of the driver, application 
software, and language support files from the CD. 

 

1. Verify that the installer detected and selected the correct support files 
and the correct version number of the application software and/or 
language. Double-click the plus sign in front of a feature to expand the 
list of feature subcomponents as shown above. You can select 
additional options to install the support files, examples, and 
documentation. Follow the software prompts. 

Note If you install NI-DAQ 7.0 first, then later install NI application software version 7.0, 
you need to run the NI-DAQ 7.0 installer again to install the correct application software 
support.

2. Click Finish. 

3. When the installer completes, a message opens asking if you want to 
restart now. Click No and shut down the computer.

If you need to install an RT Series product, refer to the Hardware 
Installation Wizard at ni.com/support/install for setup 
instructions for RT Series products.

4. Power off and unplug the computer or PXI chassis. 
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Step 4. Unpack the Devices, Accessories, and Cables
Your device is shipped in an antistatic package to prevent electrostatic 
damage (ESD) to the device. ESD can damage several components on the 
device. 

Caution Never touch the exposed pins of connectors.

To avoid such damage, take the following precautions:

• Ground yourself using a grounding strap or by holding a grounded 
object. 

• Touch the antistatic package to a metal part of the computer chassis 
before removing the device from the package. 

Remove the device from the package and inspect the device for loose 
components or any sign of damage. Notify NI if the device appears 
damaged in any way. Do not install a damaged device in the computer, 
PXI chassis, or SCXI chassis. 

Store the device in the antistatic package when the device is not in use.

For safety and compliance information, refer to the device documentation 
as described in Step 10. Browse or Install Device Documentation.

Step 5. Install the Devices, Accessories, and Cables
If you have more than one DAQ device to install, install them all now. For 
more information about the hardware specifics of your device, such as slot 
requirements, refer to the device documentation as described in Step 10. 
Browse or Install Device Documentation.

If your system includes switch or SCXI signal conditioning modules that 
will be connected to DAQ devices, first install the DAQ components using 
this guide. 

Note The following instructions do not apply to RT Series products. Refer to the 
Hardware Installation Wizard at ni.com/support/install for setup instructions for 
RT Series products.
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PCI Devices

Caution Make sure the computer is powered off. Follow proper ESD precautions to ensure 
you are grounded before installing the hardware.

Complete the following steps to install a PCI device.

1. Remove the computer cover and the expansion slot cover. 

2. Touch any metal part of the computer to discharge any static electricity.

3. Insert the device into a PCI system slot. Gently rock the device into 
place. Do not force the device into place.

 

4. Screw the device mounting bracket to the computer back panel rail.

5. Replace the computer cover.

Your PCI device is installed.

1 PCI DAQ Board
2 PCI System Slot

3 PCI Computer

1
2

3
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PXI Devices

Caution Make sure the PXI chassis is powered off. Follow proper ESD precautions to 
ensure you are grounded before installing the hardware.

Complete the following steps to install a PXI module.

1. Remove the filler panel of an unused PXI slot. For information on slot 
requirements, refer to the device documentation as described in
Step 10. Browse or Install Device Documentation.

2. Touch any metal part of the chassis to discharge any static electricity. 

3. Insert the device into the PXI slot. Use the injector/ejector handle to 
fully insert the device. 

4. Screw the device front panel to the chassis front panel mounting rail.
 

Your PXI device is installed.

1 PXI Chassis
2 PXI Module

3 Injector/Ejector Handle in Down 
Position

8

7

6

5

4

3

2

1

ON

STANDBY

1

2

3
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PCMCIA Devices
You can install an NI PCMCIA device in any available Type II PC Card 
slot. Complete the following steps to install a PCMCIA device.

Caution Make sure the computer is powered off. If your PCMCIA supports hot insertion, 
the computer may be powered on. Follow proper ESD precautions to ensure you are 
grounded before installing the hardware.

1. Remove the PCMCIA slot cover on your computer, if any.

2. Insert the PCMCIA bus connector of the PCMCIA device in the slot 
until the connector is firmly seated. NI PCMCIA devices have 
two connectors, a 68-pin PCMCIA bus connector on one end and 
an I/O connector on the other end. The PCMCIA device is keyed 
so that you can insert it only one way. 

3. Attach the I/O cable. Be careful not to put strain on the I/O cable when 
inserting or removing the cable connector. Always grasp the cable by 
the connector you are inserting or removing. Never pull directly on 
the I/O cable to unplug it from the PCMCIA device.

Your PCMCIA device is installed.

1 PCMCIA Computer
2 PCMCIA Socket
3 I/O Cable

4 Accessory
5 I/O Signals

®

1

2

3

4

5

DAQCard-700
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USB/IEEE 1394 Devices

Caution Follow proper ESD precautions to ensure you are grounded before installing the 
hardware.

Note If you are using the BP-1 battery pack, follow the installation instructions in your 
BP-1 installation guide and disregard step 1 in this guide. The following instructions are 
correct if you are not using the BP-1 battery pack.

Complete the following steps to install an NI device for USB or 1394.

1. Some NI devices for USB or 1394 require external power.

• If your device has an external power supply, verify that the voltage 
on the external power supply, if any, matches the voltage in your 
area (120 or 230 VAC) and the voltage required by your device. 
Connect one end of the power supply to an electrical outlet and the 
other end to the rear of your device.

• If your device has a power cord, connect one end of the power cord 
to the device and the other end to an electrical outlet.

2. Connect the cable from the computer USB or 1394 port or from any 
other hub or 1394 device to any available USB or 1394 port on the 
device. Tighten the mounting screws, if any, for a firm connection. 
Connect the other end of the USB or 1394 cable to the USB or 
IEEE 1394 port on the device. The following figure shows the USB 
cable and its connectors.

Your USB/IEEE 1394 device is installed. If you have a USB or IEEE 1394 
device with a rear panel power switch, power on the device. 

Accessories
Install accessories, terminal blocks, and/or SCC modules according to 
the instructions in their installation guides. For SCXI, continue with the 
instructions in this guide until Step 12. Attach Sensors and Signals.

1 Connector to the Computer 
or USB Hub

2 Connector to the Device

1 2
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Step 6. Power on Your Computer or PXI Chassis
Windows recognizes any newly installed device the first time the computer 
reboots after hardware is installed. On some Windows systems, the Found 
New Hardware Wizard opens with a dialog box for every NI device 
installed. Install the software automatically (Recommended) is selected 
by default. Click Next or Yes to install the software for each device so 
Windows recognizes the device.

When the computer recognizes a USB or IEEE 1394 device, the power 
LED on the device blinks or lights up, depending on the status of your 
device. NI devices for IEEE 1394 also have a COM LED, which should 
blink when the device is detected. For LED pattern descriptions, refer to the 
device documentation as described in Step 10. Browse or Install Device 
Documentation. 

Step 7. Launch Measurement & Automation Explorer (MAX)
Double-click the Measurement & Automation Explorer icon on the 
desktop to open MAX.

Step 8. Confirm That Your Device Is Recognized
1. Expand Devices and Interfaces. 

2. Check that your device appears under Devices and Interfaces. 

When a device is supported by both Traditional NI-DAQ and 
NI-DAQmx and both are installed, the same device is listed with a 
different name under the Traditional NI-DAQ and NI-DAQmx folders 
in Devices and Interfaces. If your device does not appear, press <F5> 
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to refresh the view in MAX. If the device is still not recognized, refer 
to ni.com\support\install for troubleshooting information.

3. Under the folder for the NI-DAQ API you are using to program the 
device, right-click the device you want to test. 

• If the device is under Traditional NI-DAQ, select Properties, 
then click Test Resources in the Properties window.

• If the device is under NI-DAQmx, select Self-Test.
 

4. When the self-test finishes, a message indicates if an error occurred. If 
an error occurs, refer to ni.com/support for troubleshooting 
information. 

Step 9. Configure Your Device Settings
Configure each device you install. To use a device in both Traditional 
NI-DAQ and NI-DAQmx, you must configure its properties in each.

1. Right-click the device name and select Properties. Be sure to click the 
device name under the folder for the NI-DAQ API in which you want 
to use the device.

2. Configure the device properties.

• If you are using an accessory, add the accessory information.

• If you are using a device in Traditional NI-DAQ, you can change 
its default settings for AI, AO, OPC, or Remote Access. Refer to 
your device documentation as described in the next step for more 
information about device default settings.

3. Click OK to accept the changes.
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Tip For devices supported by both Traditional NI-DAQ and NI-DAQmx, you can convert 
Traditional NI-DAQ virtual channel and scale configurations to an NI-DAQmx 
configuration with the Traditional NI-DAQ to NI-DAQmx Configuration Converter 
Wizard. The wizard also converts SCXI and accessory configurations, but not SCC 
configurations. You must configure SCC information separately in each API you want to 
use. Refer to the Converting Traditional NI-DAQ Configurations to NI-DAQmx 
Configurations section of the Measurement & Automation Explorer Help for NI-DAQmx 
for instructions.

Step 10. Browse or Install Device Documentation
The NI-DAQ 7.0 software distribution includes the Device Documentation 
CD, which contains online documentation for supported DAQ, SCXI, and 
switch devices. Device documentation includes help files describing device 
terminals, device features, device operation, and PDF files of the device 
documents. You can use the Device Document Browser to find, view, and 
print the documents for each device. 

You can use the NI-DAQ Device Document Browser at any time by 
inserting the NI-DAQ 7.0 Device Documentation CD. The NI-DAQ 7.0 
document browser has the following options:

• Browse Device Documents opens the document browser and displays 
the device documentation for each device. 

• Install Device Documents copies the document browser and all 
device documents to the hard drive. After installation, the browser is 
accessible from Start»Programs»National Instruments»NI-DAQ» 
Browse Device Documentation.

If the browser does not open automatically, select Start»Run and enter 
x:\autorun.exe, where x is the letter of the CD drive.

Note You must have Internet Explorer version 5.0 or later to use some features of the 
NI-DAQ 7.0 documentation, including the help system and Device Document Browser.

Step 11. Install SCXI or Switch Modules, if Applicable
If your system includes SCXI signal conditioning or switch modules to 
connect to DAQ devices, refer to the SCXI Quick Start Guide and the 
NI Switches Getting Started Guide to install and configure the SCXI and 
switch hardware.

The rest of this guide applies only to DAQ devices with terminal blocks or 
SCC accessories.
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Step 12. Attach Sensors and Signals
Wire sensors and signals to the device or accessory terminals.

Helpful information is in the following documentation: 

• Signal and terminal connections:

– The E Series Help, device user manual PDFs, and accessory PDFs 
are on the Device Document Browser.

– Pin assignments also are located in the Measurement & 
Automation Explorer Help for Traditional NI-DAQ and the 
Measurement & Automation Explorer Help for NI-DAQmx, 
accessible from the MAX Help menu.

• Switch specifications include a topology of the device.

• Using sensors:

– If you are using LabVIEW, refer to the LabVIEW Measurements 
Manual packaged with LabVIEW or available from ni.com/
manuals. 

– If you are using another programming environment and 
NI-DAQmx, refer to the Sensors topic of the NI-DAQmx Help, 
which you can access from Start»Programs»National 
Instruments» NI-DAQ»NI-DAQmx Help. 

– If you are using another programming environment and 
Traditional NI-DAQ, refer to Chapter 5, Transducer Conversion 
Functions, of the Traditional NI-DAQ User Manual, which you 
can access from Start»Programs»National Instruments»
NI-DAQ»Traditional NI-DAQ User Manual. 

Step 13. Run Test Panels
Many devices have a test panel for testing specific device functionality, 
such as the ability to acquire and generate signals.

1. Open the MAX help for operating test panels. 

a. In MAX, select Help»Help Topics»NI-DAQmx or Traditional 
NI-DAQ, whichever you will test. The MAX help opens.

b. In the Contents tab, expand the books Measurement & 
Automation Explorer»MAX for the version of NI-DAQ you 
will test»Getting Started»DAQ Devices»Testing DAQ Devices.

c. Click Testing DAQ Devices to open the help topics for operating 
the test panels.

d. Shrink the Help window and drag it to the right to uncover the 
MAX Configuration pane.
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2. Click MAX to make it the active window. 

3. Under Traditional NI-DAQ Devices or NI-DAQmx Devices, 
right-click the device to test. 

4. Select Test Panels to open a test panel for the selected device. 

An example of a test panel is shown in the following figure. 
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5. Click the tabs to test different functions of the device. Click the MAX 
Help window for instructions on operating the test panels in 
Traditional NI-DAQ and NI-DAQmx.

6. The test panel displays a message indicating if an error occurred. Refer 
to the NI-DAQmx Reference Help or ni.com/support for 
troubleshooting information. 

7. When you finish, click Close or OK to exit the test panel.

Step 14. Configure Any Additional New Devices
If you installed more than one DAQ device, repeat steps 9 through 13 for 
each device. 

Step 15. Configure Channels and Tasks
A physical channel is a terminal or pin at which you can measure or 
generate an analog or digital signal. A virtual channel is a collection of 
settings that can include a name, a physical channel, input terminal 
connections, the type of measurement or generation, and scaling 
information. In Traditional NI-DAQ and earlier versions, configuring 
virtual channels is an optional way to record which channels are being used 
for different measurements. In NI-DAQmx, virtual channels are integral to 
every measurement.

In Traditional NI-DAQ, you configure virtual channels using MAX. In 
NI-DAQmx, you can configure virtual channels with the DAQ Assistant, 
which you can open from MAX or your application software. You also can 
configure virtual channels with the NI-DAQmx API in your application 
program.

A task, an important new concept for NI-DAQmx, is a collection of one 
or more virtual channels with timing, triggering, and other properties. 
Conceptually, a task represents a measurement or generation you want to 
perform. You can set up and save all of the configuration information in a 
task and use the task in an application.

In NI-DAQmx, you can configure virtual channels as part of a task or 
separate from a task. Virtual channels created inside a task are local 
channels. Virtual channels defined outside a task are global channels. 
You can create global channels in MAX or in your application software. 
You can use global channels in any application or add them to a number of 
different tasks. If you modify a global channel, the change affects all tasks 
in which you reference that global channel. In most cases, it is simpler to 
use local channels.
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Configure a Task in NI-DAQmx
Configure tasks with the DAQ Assistant when you use NI-DAQmx. You 
must have version 7.0 of an NI application software package to create tasks 
and channels with the DAQ Assistant.

• In MAX, right-click Data Neighborhood and select Create New. In 
the Create New window, select NI-DAQmx Task and click Next.

• You also can open the DAQ Assistant directly from within 
NI application software.

– In LabVIEW, there are several ways to open the DAQ Assistant:

• Drop the DAQ Assistant Express VI from the Express Input 
palette, as described in Getting Started with LabVIEW. 

• You also can use the DAQmx Task Name control to open the 
DAQ Assistant. Right-click the control and select New Task 
(DAQ Assistant). The Taking an NI-DAQmx Measurement 
in LabVIEW help tutorial has step-by-step instructions on 
how to create a task from the DAQmx Task Name control and 
generate code for the task. In LabVIEW, select Help»Taking 
an NI-DAQmx Measurement to open the tutorial.

– In LabWindows/CVI, select Tools»Create/Edit DAQmx Tasks. 

– In Measurement Studio, open Visual Studio .NET and select 
Project»Add New Item to open the Add New Item dialog box. In 
the Categories pane, select Measurement Studio»Assistants. In 
the Templates pane, select DAQmx Task Class.

The DAQ Assistant opens.
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Follow the online instructions to create a new task. 

1. Select an I/O type, such as analog input.

2. Select the measurement or generation to perform.

3. Choose the sensor to use, if applicable.

4. Select the channels to add to the task. You can add global channels to 
the task or select physical channels from which to create local channels 
in the task.

5. Configure measurement-specific settings, timing, and triggering, 
if necessary. 

6. Save the task.

• If you opened the DAQ Assistant from LabVIEW or 
LabWindows/CVI, click OK. 

• If you opened the DAQ Assistant from Measurement Studio, 
select File»Save. 

• If you opened the DAQ Assistant from MAX, click Save Task. 

You now can use the task in an application. Refer to the DAQ Assistant 
Help or application software documentation for more information about 
using a task or generating code.

Configure Global Channels for NI-DAQmx
Configure global channels with the DAQ Assistant when you use 
NI-DAQmx.

• In MAX, right-click Data Neighborhood and select Create New. 
In the Create New window, select NI-DAQmx Global Channel and 
click Next.

• You also can open the DAQ Assistant directly from within 
LabVIEW 7.0, LabWindows/CVI 7.0, or Measurement Studio 7.0.

– In LabVIEW, use the DAQmx Global Channel control to open the 
DAQ Assistant. Right-click the control and select New Channel 
(DAQ Assistant).

– In LabWindows/CVI or Measurement Studio, you first must 
create a task as previously described. In the DAQ Assistant, click 
Add Existing DAQmx Global Channels to add global channels 
to your task. 

The DAQ Assistant opens. Follow the online instructions to create a new 
global channel.

1. Select an I/O type, such as analog input. 

2. Select the measurement or generation to perform. 

3. Choose the sensor to use, if applicable. 
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4. Select the physical channels to use. 

5. Configure measurement-specific settings. 

6. Save the task.

• If you opened the DAQ Assistant from LabVIEW or 
LabWindows/CVI, click OK. 

• If you opened the DAQ Assistant from Measurement Studio, 
select File»Save. 

• If you opened the DAQ Assistant from MAX, click Save 
Channel. 

You now can use the global channel in an application or add the global 
channel to a task. Refer to the DAQ Assistant Help or application software 
documentation for more information about using a channel or generating 
code.

Configure Virtual Channels for Traditional NI-DAQ
When you use Traditional NI-DAQ, configure virtual channels in MAX. 

1. In MAX, right-click Data Neighborhood and select Create New. 

2. Select Traditional NI-DAQ Virtual Channel in the Create New 
window and click Finish. The Create New Channel Wizard opens. 

3. Follow the instructions in the Create New Channel Wizard to create a 
new channel. For additional information about configuring different 
channel types, refer to the Measurement & Automation Explorer Help 
for Traditional NI-DAQ.
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Getting Started Developing an Application

Examples
Each API includes a collection of programming examples to help you get 
started developing an application. You can modify example code and save 
it in an application. You can use examples to develop a new application or 
add example code to an existing application.

To locate LabVIEW and LabWindows/CVI examples, open the National 
Instruments Example Finder.

• In LabVIEW, select Help»Find Examples.

• In LabWindows/CVI, select Help»NI Example Finder.

Measurement Studio, Visual Basic, and ANSI C examples are in the 
following directories:

• NI-DAQmx examples for Measurement Studio-supported languages 
are in the following directories:

– MeasurementStudio\VCNET\Examples\DAQmx 

– MeasurementStudio\DotNET\Examples\DAQmx

• Traditional NI-DAQ examples for Visual Basic are in the following 
directories:

– The NI-DAQ\Examples\Visual Basic with Measurement 
Studio directory contains a link to the ActiveX control examples 
for use with Measurement Studio 

– The NI-DAQ\Examples\VBasic directory contains the 
examples not associated with Measurement Studio

• NI-DAQmx examples for ANSI C are in the NI-DAQ\Examples\
DAQmx ANSI C directory.

• Traditional NI-DAQ examples for ANSI C are in the NI-DAQ\
Examples\VisualC directory.

For additional examples, refer to ni.com/zone.

Information about Measurement Applications and Devices
Each application software package and driver includes information about 
writing applications for taking measurements and controlling measurement 
devices. The following references to documents assume you have 
NI-DAQ 7.0, and where applicable, version 7.0 of the NI application 
software.
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LabVIEW
If you are a new user, read Getting Started with LabVIEW to get acquainted 
with LabVIEW. Select Start»Programs»National Instruments»
LabVIEW»Search the LabVIEW Bookshelf. 

The LabVIEW Measurements Manual contains API overviews of 
Traditional NI-DAQ and NI-DAQmx, and describes measurement 
concepts. Select Start»Programs»National Instruments»LabVIEW» 
Search the LabVIEW Bookshelf.

The Taking an NI-DAQmx Measurement in LabVIEW help tutorial has 
step-by-step instructions on how to set up a measurement in LabVIEW and 
describes key new NI-DAQmx features and concepts such as the DAQ 
Assistant and tasks. Select Help»Taking an NI-DAQmx Measurement in 
LabVIEW to open the tutorial.

The LabVIEW Traditional NI-DAQ VI Reference Help and the LabVIEW 
NI-DAQmx VI Reference Help describe the LabVIEW VIs and properties. 
In LabVIEW, select Help and the LabVIEW VI reference help for the 
NI-DAQ API you are using. 

LabWindows/CVI
The Data Acquisition Library book of the main LabWindows/CVI Help 
contains API overviews, measurement concepts, and function references 
for Traditional NI-DAQ and NI-DAQmx. In LabWindows/CVI, select 
Help»Contents.

Measurement Studio
The NI Measurement Studio Help contains the NI-DAQmx API overview, 
measurement tasks and concepts, and function reference. This help file is 
integrated into the Visual Studio .NET documentation. In Visual Studio 
.NET, select Help»Contents.

The Measurement Studio Reference contains the Traditional NI-DAQ API 
overview, measurement concepts, and function reference. In Visual Studio 
.NET, select Measurement Studio»Measurement Studio Reference. 

ANSI C without NI Application Software
The Traditional NI-DAQ User Manual and the NI-DAQmx Help contain 
API overviews. The NI-DAQmx Help also contains general information 
about measurement concepts. The Traditional NI-DAQ C Reference Help 
and the NI-DAQmx C Reference Help describe the C functions and 
attributes. Select Start»Programs»National Instruments»NI-DAQ and 
the document title for the NI-DAQ API you are using.
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.NET Languages without NI Application Software
The NI Measurement Studio Help contains the NI-DAQmx API overview, 
measurement tasks and concepts, and function reference. This help file is 
integrated into the Visual Studio .NET documentation. In Visual Studio 
.NET, select Help»Contents.

Note If you use a .NET language without Visual Studio .NET, you might not be able to 
view the NI Measurement Studio Help.

Device Documentation
NI-DAQ 7.0 includes the Device Document Browser, which contains 
online documentation for supported DAQ, SCXI, and switch devices, such 
as help files describing device pinouts, features, and operation, and PDF 
files of the printed device documents. You can find, view, and/or print the 
documents for each device using the Device Document Browser at any 
time by inserting the CD. After installing the Device Document Browser, 
device documents are accessible from Start»Programs»National 
Instruments»NI-DAQ»Browse Device Documentation. 

SCXI and Switch Multi-Chassis Configurations
The SCXI-1346 Shielded Multi-Chassis Cable Adapter Installation Guide 
contains setup instructions for developing SCXI and switch multi-chassis 
applications.

Switch 
The NI Switches Help contains technical and programming support for the 
switch module and the NI-SWITCH instrument driver.

The NI-SWITCH Instrument Driver Quick Reference Guide contains an 
API overview and function/VI overview.

Training Courses
If you need more help getting started developing an application with 
NI products, NI offers training courses. To enroll in a course or obtain 
a detailed course outline, refer to ni.com/training. 

Technical Support
For additional support, refer to ni.com/support or ni.com/zone. 
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Using Traditional NI-DAQ and NI-DAQmx on the 
Same Computer

Existing applications developed with earlier versions of NI-DAQ will run 
under Traditional NI-DAQ. You can use both the Traditional NI-DAQ API 
and the NI-DAQmx API on the same computer with the following 
restrictions:

• Only one API controls a given device at one time.

– After using a device in NI-DAQmx, you must unreserve all 
NI-DAQmx tasks that are using that device before you can use that 
device through Traditional NI-DAQ. To unreserve NI-DAQmx 
tasks, call the DAQmx Clear Task VIs or functions. 

– After using a device in Traditional NI-DAQ, you must reset the 
device before you can use that device in NI-DAQmx. For SCXI 
devices, you must reset the communicator DAQ device.

• Call the Traditional NI-DAQ Device Reset VI or the 
Init_DA_Brds function. 

• To reset all devices in Traditional NI-DAQ, right-click the 
Traditional NI-DAQ Devices folder in MAX and select 
Reset Driver for Traditional NI-DAQ. 

• You must use the same API to program all devices—connected DAQ 
devices and inserted SCXI modules—in an SCXI data acquisition 
system.

Refer to ni.com/support for details and instructions about the following 
topics:

• How to add NI-DAQmx code to a Traditional NI-DAQ application

• How to run both Traditional NI-DAQ applications and NI-DAQmx 
applications that use the same device
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Operating System, Application Software, Programming 
Language, and Device Support in NI-DAQ 7.0

Version 7.0 of NI-DAQmx does not yet support the full line of NI 
measurement devices. The next few releases of NI-DAQ will add support 
for new and existing devices in NI-DAQmx, and will continue to include 
Traditional NI-DAQ.

Operating System Support
NI-DAQmx, Traditional NI-DAQ, and NI-SWITCH 2.0 support 
Windows 2000/NT/XP/Me/98. NI-DAQ 7.0 on Windows NT requires 
Service Pack 6 or later. Measurement Studio requires Visual Studio 
.NET 2003, which requires Windows 2000/NT 4.0/XP. For operating 
system-specific installation instructions, use the Hardware Installation 
Wizard at ni.com/support/install.

To find and download an earlier version of NI-DAQ that supports other 
operating systems, refer to ni.com/downloads. 

Application Software and Programming Language Support
Table 1 lists the application software versions supported by NI-DAQmx 
and Traditional NI-DAQ. If you are not using NI application software, refer 
to Table 2.

 
Table 1.  NI-DAQ 7.0 Application Software Support

NI Application Software

Versions 
Supported by 
NI-DAQmx

Versions 
Supported by 

Traditional 
NI-DAQ

LabVIEW  7.0 6.0–7.0

LabVIEW RT module — 6.0–7.01 

LabWindows/CVI  7.0 6.0–7.0

Measurement Studio  7.0 6.0–7.02

1 LabVIEW RT users must use Traditional NI-DAQ for their DAQ applications. A future 
version of NI-DAQmx will support LabVIEW RT.
2 Traditional NI-DAQ does not include a Measurement Studio C++ or .NET interface.
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Table 2 lists the programming languages and versions supported by 
NI-DAQmx and Traditional NI-DAQ. 

 

Earlier versions of NI-DAQ support other application software and 
language versions. To find and download an earlier version of a driver, 
refer to ni.com/downloads.

Device Support
For specific device model names, refer to the NI-DAQ 7.0 Readme file on 
the CD. Table 3 lists the families of devices supported by NI-DAQmx, 
Traditional NI-DAQ, and NI-SWITCH 2.0. 

Table 2.  NI-DAQ 7.0 Programming Language Support

Programming Language

Versions 
Supported by 
NI-DAQmx

Versions 
Supported by 

Traditional 
NI-DAQ

ANSI C ✓ ✓

Microsoft Visual C++
Class libraries
C DLL

7.01

6.0–7.0
—

6.0–7.0

Visual Basic 6.0 through ActiveX — 6.0

Microsoft .NET languages 
(C# and Visual Basic .NET)

.NET 1.1 —

1 Requires Measurement Studio version 7.0.

Table 3.  NI-DAQ 7.0 Device Support

Device NI-DAQmx
Traditional 

NI-DAQ NI-SWITCH 2.0

PCI and PXI E Series multifunction DAQ 
devices, such as the NI PCI-6052E

✓ ✓ not applicable

DAQPad devices for USB and FireWire 
(IEEE 1394)

— ✓ not applicable

DAQCard E Series PCMCIA devices — ✓ not applicable

NI PCI-6013/6014 16-bit basic 
multifunction DAQ devices

— ✓ not applicable

S Series multifunction DAQ devices, 
such as the NI PXI-6115

— ✓ not applicable
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Refer to the NI-DAQ 7.0 Readme file on the NI-DAQ 7.0 CD for the list of 
new devices supported by NI-DAQ 7.0.

More Devices in Future Releases of NI-DAQmx
Future releases of NI-DAQ will support additional devices in NI-DAQmx 
that are currently supported only in Traditional NI-DAQ. 

Digital I/O devices, such as the NI 653X 
family of devices

— ✓ not applicable

NI PCI-4551, PCI-4552, and PCI and 
PXI-4472 dynamic signal acquisition 
devices

— ✓ not applicable

NI PCI and PXI 671X/673X analog output 
devices

— ✓ not applicable

NI 660X counter/timer I/O devices — ✓ not applicable

NI SCXI-1530, SCXI-1531, 
and SCXI-1540 signal conditioning 
modules

✓1 ✓ not applicable

All other SCXI signal conditioning 
modules

✓ ✓ not applicable

SCC Series signal conditioning modules ✓ ✓ not applicable

NI SCXI-1166 and SCXI-1193 switch 
modules

✓ — ✓

All other SCXI switch modules ✓ ✓ ✓

NI PXI-2566 and PXI-2593 switch 
modules

✓ — ✓

All other PXI switch modules — — ✓

NI PXI-4204 and PXI-4220 modules ✓ — —

1 These devices are supported in NI-DAQmx without support for accelerometer, linear-voltage differential transformer 
(LVDT), and rotary variable-differential transformer (RVDT) virtual channels.

Table 3.  NI-DAQ 7.0 Device Support (Continued)

Device NI-DAQmx
Traditional 

NI-DAQ NI-SWITCH 2.0
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Devices Restricted to Traditional NI-DAQ
NI-DAQmx does not support the following devices and will not support 
them in future NI-DAQ releases. The following devices are supported 
only in Traditional NI-DAQ.

• AT E Series devices 

• AT-AO-6/10 analog output devices 

• AT-DIO-32F 32-bit parallel DIO devices

• DAQCard-AI-16E-4 and DAQCard-AI-16XE-50 PCMCIA devices

• NI PCI-4451/4452/4454 dynamic signal acquisition and generation 
devices

• NI 4350/4351 data loggers

Devices No Longer Supported in NI-DAQ 7.0
The following products are not supported in NI-DAQ 7.0—in neither 
NI-DAQmx nor Traditional NI-DAQ—and will not be supported in future 
versions of NI-DAQ. You must use NI-DAQ 6.9.x or earlier to program 
these devices.

• AT-MIO-16F-5 multifunction DAQ device

• DAQCard-500, DAQCard-516, DAQCard-700, DAQCard-1200, and 
DAQCard-AO-2DC PCMCIA devices

• DAQPad-1200 and DAQPad-MIO-16XE-50 devices for parallel port

• Lab-PC family of ISA and PC/XT MIO devices

• PC-516 16-bit, 50 kS/s MIO device

• PC-AO-2DC low-cost AO and current loop DAQ device

• PC-LPM-16PnP MIO device for the PC

• PC-OPDIO-16 optically isolated DIO device for the PC

• PC-TIO-10 timing and DIO interface for the PC

• PCI-1200 12-bit, 100 kS/s MIO device

• SCXI-1200 12-bit DAQ and control module

• SCXI-2000 4-slot chassis

• SCXI-2400 serial interface module

• VXI DAQ modules, VXI-SC carriers and modules, and VXI-TB 
terminal blocks for VXI bus
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